Schema include and SQL editor

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Schema include and SQL editor

Federico Bruni
Hi folks

In my session properties' object tree I've put the name of the schema I want to load in "Schema include". So every time I open a session only that schema is included.

I supposed that I should not need to set the schema in the SQL editor when running a query.
But it seems that the set command is needed _only the first time a query is run_. If I open a file without the set command, it doesn't work at first; if i add it it works; if I remove it it keeps working within the current session.

Is it sensible?

I should conclude that I must keep the set command in my query files?
SET SCHEMA schema_name;

Thanks for any explanation
Federico

------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Squirrel-sql-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/squirrel-sql-users
Reply | Threaded
Open this post in threaded view
|

Re: Schema include and SQL editor

Federico Bruni
It does happen also in the Query builder, not only in the SQL editor.
Each time I launch SquirrelSQL, I must run the command "SET SCHEMA..." in the SQL editor and then the queries will work as expected.
This is a bit annoying, especially if I want SquirrelSQL to be used by other people.

I realized that I asked almost the same question one year and a half ago:
https://sourceforge.net/p/squirrel-sql/mailman/message/32655580/

What I'm trying to do now is executing the "SET SCHEMA.." at startup.
I hoped that the keep-alive connection setting in the alias properties could help, but it didn't.




2016-02-10 17:48 GMT+01:00 Federico Bruni <[hidden email]>:
Hi folks

In my session properties' object tree I've put the name of the schema I want to load in "Schema include". So every time I open a session only that schema is included.

I supposed that I should not need to set the schema in the SQL editor when running a query.
But it seems that the set command is needed _only the first time a query is run_. If I open a file without the set command, it doesn't work at first; if i add it it works; if I remove it it keeps working within the current session.

Is it sensible?

I should conclude that I must keep the set command in my query files?
SET SCHEMA schema_name;

Thanks for any explanation
Federico


------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Squirrel-sql-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/squirrel-sql-users