Minimum requirements

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Minimum requirements

Haxwell
Hey all..

Are there minimum requirements defined for Squirrel? Particularly, what is
the minimum version of Java required?

Johnathan
-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Squirrel-sql-develop mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/squirrel-sql-develop
Reply | Threaded
Open this post in threaded view
|

Re: Minimum requirements

Robert Manning
On Thu, Aug 28, 2008 at 2:06 AM, Johnathan James <[hidden email]> wrote:

> Hey all..
>
> Are there minimum requirements defined for Squirrel? Particularly, what is
> the minimum version of Java required?
>

Java5 (1.5).  We decided we would move forward only when we are two revs
behind.  So when Java7 is released, we start requiring a minimum version of
Java6 (1.6).

Rob
-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Squirrel-sql-develop mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/squirrel-sql-develop
Reply | Threaded
Open this post in threaded view
|

Re: Minimum requirements

Haxwell
In that case, in order to fix the bug that I was referring to earlier, all
that is necessary is to remove the internalFrameActivated() method from the
internalFrameListener() added in the createGUI() method of the class
SessionInternalFrame. It seems the Java bug that necessitated that method,
has been fixed as of at least Java 1.5.

I would have wrote a patch, but I figured it was easier to write an email.
Ha. Sorry, its the weekend...

Let me know if that works for you..

On Thu, Aug 28, 2008 at 4:49 AM, Robert Manning
<[hidden email]>wrote:

>
>
> On Thu, Aug 28, 2008 at 2:06 AM, Johnathan James <[hidden email]>wrote:
>
>> Hey all..
>>
>> Are there minimum requirements defined for Squirrel? Particularly, what is
>> the minimum version of Java required?
>>
>
> Java5 (1.5).  We decided we would move forward only when we are two revs
> behind.  So when Java7 is released, we start requiring a minimum version of
> Java6 (1.6).
>
> Rob
>
>
-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Squirrel-sql-develop mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/squirrel-sql-develop
Reply | Threaded
Open this post in threaded view
|

Re: Minimum requirements

Robert Manning
On Sun, Aug 31, 2008 at 8:40 PM, Johnathan James <[hidden email]> wrote:

> In that case, in order to fix the bug that I was referring to earlier, all
> that is necessary is to remove the internalFrameActivated() method from the
> internalFrameListener() added in the createGUI() method of the class
> SessionInternalFrame. It seems the Java bug that necessitated that method,
> has been fixed as of at least Java 1.5.
>
> I would have wrote a patch, but I figured it was easier to write an email.
> Ha. Sorry, its the weekend...
>
> Let me know if that works for you..
>

I tested it and it seemed to work fine, so I committed it.  It's on the
trunk now and will
be available in 2.6.7 in the coming weeks.   I listed it in changes.txt and
gave you credit
for the fix.  Thanks for your help!

Rob
-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Squirrel-sql-develop mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/squirrel-sql-develop